Resolved
The issue has been resolved and you should be seeing no slowness in the Braintrust Control Plane UI. Please let us know if you have any issues.
Investigating
At the current moment in time we have reports of hanging in the UI particularly in dataset or trace views.
We are currently narrowing down the code change causing the issue. Please stand by we are aware and currently working to resolve.